Follow

How To Do A Little Planet Video With VideoStitch Studio And PTGui

This tutorial explains how to create a little planet video with VideoStitch Studio.

It requires PTGui.

 

  • Make a calibration of your scene in PTGui

  • Change the projection to stereographic (in Projection > Stereographic). Do not use the stereographic down projection

  • Go in "Numerical Transform" ("123" menu on the top), input -90 as the pitch value and apply

  • Save the template (In PTGui main window: File > Save as template)

 

  • Import the template into VideoStitch Studio

In Studio, go in the "Window" menu and click on "Calibration" then "Import template"

Then click on "Browse calibration" and import the template

  • Save your project as a ptv file (not ptvb) (File > Save project as)
  • Open the ptv file in a text editor

You will find at the top of the file the description of the output panorama

"pano" : {
"width" : 2048,
"height" : 1024,
"pad_top" : 0,
"pad_bottom" : 0,
"hfov" : 360,
"proj" : "equirectangular",
"global_orientation" : [
1,
0,
0,
0
],
"stabilization" : [
1,
0,
0,
0
],

Change "hfov" value to 320 and "proj" value to stereographic

},
"pano" : {
"width" : 2048,
"height" : 1024,
"pad_top" : 0,
"pad_bottom" : 0,
"hfov" : 320,
"proj" : "stereographic",
"global_orientation" : [
1,
0,
0,
0
],

Then save your file.

  • Open the project file in VideoStitch Studio

  • You can apply exposure compensation and other correction algorithms if needed
  • Process the file and enjoy

Here is the result in VLC:

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.